Forum Forum Magento Theme SNS Furni – Magento Theme Mega Menu admin report

  • Author
  • #10525



      The tab “Menu Items Manager” doesn’t work properly with a fresh install of your theme.
      As a matter of fact, I have two instances of Magento with your theme, one with the quickstart theme and one with fresh magento installation.

      I noticed a few bugs with the quickstart (for example : deleted every store except one, but they remained present in database, which confused magento by making it believe there were tones of stores….). Thus, I decided to go with a fresh install.

      But… When I try to go to the admin tab “Menu Items Manager”, I have the following error :

      SQLSTATE[42S22]: Column not found: 1054 Champ ‘CONCAT( REPEAT( “— “, (COUNT(parent.depth) – 1) ) , main_table.title)’ inconnu dans field list, query was: SELECTmain_table.*,mgroup.titleASgroup_name,CONCAT( REPEAT( "--- ", (COUNT(parent.depth) - 1) ) , main_table.title)ASnameFROMsns_menu_itemsASmain_table
      INNER JOIN sns_menu_groups AS mgroup ON = main_table.group_id
      CROSS JOIN sns_menu_items AS parent WHERE (main_table.lft BETWEEN parent.lft AND parent.rgt) AND (parent.group_id = main_table.group_id) GROUP BY ORDER BY main_table.group_id ASC, main_table.lft ASC, id ASC LIMIT 20

      After debuging, I found that the problem was coming from this line (file app/code/local/Sns/Megamenu/Block/Adminhtml/Menuitems/Grid.php line 20) :
      ->columns('CONCAT( REPEAT( "'.Sns_Megamenu_Model_System_Config_Source_Prefix::PREFIX.' ", (COUNT(parent.depth) - 1) ) , main_table.title) AS name')

      and I had to remove the <<‘.Sns_Megamenu_Model_System_Config_Source_Prefix::PREFIX.’>> part to make it work.

      But this still doesn’t completely fix it. Indeed, when I click on the group’s root, I get the following error : Fatal error: Call to a member function getId() on a non-object in app/code/local/Sns/Megamenu/Block/Adminhtml/Menuitems/Edit/Tab/Form.php on line 16 and if I try to create a new item, the parent field is empty and just has “Please select” in dropdown.

      Can you please explain why I had to do this to make this tab work with a fresh install?
      Moreover, I searched all over your extensions, and this prefix seems to be used in the following file too : app/code/local/Sns/Megamenu/Helper/Data.php (line 264) and I’m afraid this causes another bug.


      Another point I’d like to submit is that you should be careful with your JS variables. In fact, you have lots of problems with translations texts as the content of your JS variables are not escaped correctly, which breaks everything if, for example, a translation has a quote!


      Finally, I tried (in the quickstart version that works) to activate the horizontal menu and associated it with the menu group ID 3 (corresponding to the mega menu horizontal in your demo) but it doesn’t work neither.
      The following error appears in my browser’s console : “Uncaught TypeError: Cannot read property ‘left’ of undefined”, caused in file skin/frontend/default/sns_furni/sns/megamenu/js/mega_menu.js line 9. This line tries to use the DOM element “#sns_menu .container” but it doesn’t exist…

      I must say even though the theme is really beautiful and has a lots of options, the amount of bugs noticed at the first hour is huge and I’m really worried for the futur…

      I hope you’ll help me as soon as possible with those bugs.

      Thank you for your attention.

    You must be logged in to reply to this topic. Click here to login or register