I got it working after many many hours of troubleshooting. It should be stated in the description that it is not compatible with the newest version of Magento and also that the Cpanel icon should be click and the menu set to mega-menu instead of base and then the Cpanel should be disabled. I don’t know if this is a bug or not but when you set the Menu style to Mega inside the SNS Nino – config it should make it so the menu on the frontend is the Mega Menu and not the setting inside of Cpanel.